🔍 CVE-2026-22704

8.0
CVSS Score
HIGH
2026-01-10
2026-01-10 07:16
✅ 완료

🇰🇷 한글 설명

HAX CMS에서 저장된 XSS 취약점이 발견되어 계정 접근이 가능해질 수 있음

💡 쉬운 설명

HAX CMS는 마이크로 사이트를 관리하는 플랫폼으로, PHP 또는 NodeJs 백엔드를 사용한다. 버전 11.0.6부터 25.0.0 이전까지의 버전에서 저장된 XSS 취약점이 발견되어 공격자가 계정 접근을 할 수 있다. 이는 사용자 계정 정보를 탈취할 수 있는 취약점이다.

🇺🇸 원문 (English)

HAX CMS helps manage microsite universe with PHP or NodeJs backends. In versions 11.0.6 to before 25.0.0, HAX CMS is vulnerable to stored XSS, which could lead to account takeover. This issue has been patched in version 25.0.0.

📍 영향받는 시스템

HAX CMS 11.0.6 ~ 24.9.9

⚔️ 공격 벡터

사용자가 입력한 데이터를 검증하지 않고 저장하여 XSS 공격이 가능해짐

🛡️ 대응 방법

HAX CMS를 버전 25.0.0 이상으로 업데이트하거나, 입력 데이터를 검증하여 XSS 공격을 방지하는 보안 패치를 적용

🔧 검증 코드

로컬에서 Python을 사용하여 HAX CMS 버전을 확인한다. 예제 코드는 https://example.com/hax-cms-version에 요청을 보내서 버전을 확인한다. 버전이 25.0.0 이상이면 양호, 미만이면 취약으로 판단한다. 필요한 권한은 None, 의존성은 requests 라이브러리이다.

Shell / Script
python -c "import requests; r = requests.get('https://example.com/hax-cms-version'); print('25.0.0' in r.text)" && echo {"result": "양호", "reason": "HAX CMS 버전이 25.0.0 이상"} || echo {"result": "취약", "reason": "HAX CMS 버전이 25.0.0 미만"}

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP