🔍 CVE-2026-23490

7.5
CVSS Score
HIGH
2026-01-16
2026-09-09 13:18
✅ 완료

🇰🇷 한글 설명

Python의 pyasn1 라이브러리에서 RELATIVE-OID에 과도한 연속 옥텟이 포함된 경우 서비스 거부 공격으로 인해 메모리 고갈이 발생할 수 있는 취약점이 발견되었습니다. 이 취약점은 0.6.2 버전에서 수정되었습니다.

💡 쉬운 설명

pyasn1 라이브러리는 Python에서 ASN.1을 처리하는 데 사용됩니다. 이 라이브러리의 이전 버전에서는 잘못된 RELATIVE-OID 요청으로 인해 시스템이 다운될 수 있습니다. 이 취약점은 0.6.2 버전에서 수정되었습니다.

🇺🇸 원문 (English)

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.2, a Denial-of-Service issue has been found that leads to memory exhaustion from malformed RELATIVE-OID with excessive continuation octets. This vulnerability is fixed in 0.6.2.

📍 영향받는 시스템

pyasn1 라이브러리 버전 0.6.2 이전

⚔️ 공격 벡터

공격자는 RELATIVE-OID 요청에 과도한 연속 옥텟을 포함시켜 시스템의 메모리를 고갈시킬 수 있습니다.

🛡️ 대응 방법

pyasn1 라이브러리를 0.6.2 버전 이상으로 업데이트하세요.

🔧 검증 코드

이 코드는 로컬 시스템에 pyasn1 라이브러리가 설치되어 있는지 확인하고, 버전을 확인하여 취약점 여부를 판단합니다. Python이 설치되어 있고, pyasn1 라이브러리가 설치된 상태에서 이 코드를 실행하면 결과가 출력됩니다.

Shell / Script
import pkg_resources
try:
    version = pkg_resources.get_distribution('pyasn1').version
    if version < '0.6.2':
        print({"result": "취약", "reason": "pyasn1 버전이 0.6.2 미만입니다."})
    else:
        print({"result": "양호", "reason": "pyasn1 버전이 0.6.2 이상입니다."})
except pkg_resources.DistributionNotFound:
    print({"result": "미설치", "reason": "pyasn1 라이브러리가 설치되어 있지 않습니다."})

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Python