🔍 CVE-2026-23498

7.2
CVSS Score
HIGH
2026-01-14
2026-01-14 19:16
✅ 완료

🇰🇷 한글 설명

Shopware 오픈 커머스 플랫폼에서 발생하는 취약점으로, 6.7.0.0부터 6.7.6.1 이전 버전까지 영향을 받습니다. CVE-2023-2017의 회귀로 인해 PHP Closure가 allow list에 대해 제대로 검사되지 않아 공격자가 악의적인 코드를 실행할 수 있습니다.

💡 쉬운 설명

Shopware 플랫폼의 취약점으로 인해 공격자가 악의적인 코드를 실행할 수 있습니다. 이는 Shopware 6.7.0.0부터 6.7.6.1 이전 버전에서 발생합니다. 최신 버전으로 업데이트하여 취약점을 해결할 수 있습니다.

🇺🇸 원문 (English)

Shopware is an open commerce platform. From 6.7.0.0 to before 6.7.6.1, a regression of CVE-2023-2017 leads to an array and array crafted PHP Closure not checked being against allow list for the map(...) override. This vulnerability is fixed in 6.7.6.1.

📍 영향받는 시스템

Shopware 6.7.0.0 ~ 6.7.6.1

⚔️ 공격 벡터

공격자는 악의적인 PHP Closure를 allow list에 등록하지 않고도 실행할 수 있습니다.

🛡️ 대응 방법

최신 버전의 Shopware(6.7.6.1 이상)으로 업데이트하여 취약점을 해결합니다.

🔧 검증 코드

로컬에서 Python을 실행하여 Shopware 버전을 확인합니다. https://example.com/shopware를 Shopware가 설치된 실제 URL로 대체합니다. Python 3.x와 requests 라이브러리가 필요합니다.

Shell / Script
python -c "import requests; response = requests.get('https://example.com/shopware'); if 'Shopware 6.7.0.0' <= response.headers.get('X-Shopware-Version', '') < '6.7.6.1': print('{{"result": "취약", "reason": "Shopware 버전이 취약한 버전입니다."}}'); else: print('{{"result": "양호", "reason": "Shopware 버전이 안전한 버전입니다."}}')"

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP