🔍 CVE-2026-24135

0.0
CVSS Score
UNKNOWN
2026-02-06
2026-02-06 21:57
✅ 완료

🇰🇷 한글 설명

Gogs는 오픈 소스 자체 호스팅 Git 서비스입니다. 버전 0.13.3 및 이전에서 updateWikiPage 함수에 경로 조작 취약성이 존재합니다. 이 취약성은 인증된 사용자가 저장소의 위키에 대한 쓰기 접근 권한을 가지고 있을 때 위키 편집 양식의 old_title 매개 변수를 조작하여 서버上的 임의 파일을 삭제할 수 있습니다. 이 문제는 버전 0.13.4 및 0.14.0+dev에서 패치되었습니다.

💡 쉬운 설명

Gogs 사용자에게 위키 편집을 통해 서버 파일을 삭제할 수 있는 취약성이 있습니다. 이는 인증된 사용자만이 공격할 수 있습니다. 최신 버전으로 업데이트하면 이 문제가 해결됩니다.

🇺🇸 원문 (English)

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, a path traversal vulnerability exists in the updateWikiPage function of Gogs. The vulnerability allows an authenticated user with write access to a repository's wiki to delete arbitrary files on the server by manipulating the old_title parameter in the wiki editing form. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

📍 영향받는 시스템

Gogs 버전 0.13.3 및 이전

⚔️ 공격 벡터

위키 편집 양식의 old_title 매개 변수 조작

🛡️ 대응 방법

Gogs를 버전 0.13.4 또는 0.14.0+dev로 업데이트합니다.

🔧 검증 코드

로컬에서 Python을 사용하여 Gogs의 최신 태그를 확인합니다. 이 코드는 Git을 사용하여 Gogs 저장소의 태그를 가져와서 0.13.4 이상의 버전이 있는지 확인합니다. 코드를 실행하기 전에 Python과 Git이 설치되어 있어야 합니다.

Shell / Script
python -c "import subprocess; output = subprocess.check_output(['git', 'ls-remote', '--tags', 'https://github.com/gogs/gogs.git']).decode('utf-8'); if 'refs/tags/v0.13.4' not in output: print('{"result": "취약", "reason": "Gogs 버전이 0.13.4 미만"}'); else: print('{"result": "양호", "reason": "Gogs 버전이 0.13.4 이상"}')"

💻 영향받는 소프트웨어

Git