🇰🇷 한글 설명
Apache Tomcat Native 및 Apache Tomcat에서 OCSP 응답에 대한 검증 및 최신성 확인이 제대로 이루어지지 않는 입력값 검증 미흡 취약점이 발견되었습니다. 이로 인해 인증서 폐기 여부를 확인하는 과정이 우회될 수 있습니다.
💡 쉬운 설명
인증서가 취소되었는지 확인하는 절차에 허점이 있어, 유효하지 않은 인증서가 통과될 수 있는 보안 결함입니다. 공격자가 폐기된 인증서를 사용하여 시스템에 접근할 위험이 있습니다.
🇺🇸 원문 (English)
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.
When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed.
This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114.
The following versions were EOL at the time the CVE was created but are
known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected.
Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue.
Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
📍 영향받는 시스템
Apache Tomcat Native (1.3.0-1.3.4, 2.0.0-2.0.11, EOL 1.1.23-1.1.34, 1.2.0-1.2.39), Apache Tomcat (11.0.0-M1-11.0.17, 10.1.0-M7-10.1.51, 9.0.83-9.0.114)
⚔️ 공격 벡터
조작된 또는 오래된 OCSP 응답을 사용하여 인증서 폐기 검증 과정을 우회하는 방식
🛡️ 대응 방법
Apache Tomcat Native를 1.3.5 또는 2.0.12 이상으로, Apache Tomcat을 11.0.18, 10.1.52, 또는 9.0.115 이상으로 업그레이드하십시오.
🔧 검증 코드
출력된 버전이 취약한 버전 범위에 포함되는지 확인하여 업그레이드 필요 여부를 판단합니다.
rpm -qa | grep -E 'tomcat|tomcat-native' || dpkg -l | grep -E 'tomcat|tomcat-native'