🔍 CVE-2026-25761

8.8
CVSS Score
HIGH
2026-02-09
2026-02-09 21:55
✅ 완료

🇰🇷 한글 설명

Super-linter GitHub Action에서 명령어 주입 취약점이 발견되었습니다. 6.0.0부터 8.3.0까지의 버전에 영향을 미치며, 공격자는 pull request를 통해 특정 파일을 추가하여 임의의 명령어를 실행할 수 있습니다.

💡 쉬운 설명

Super-linter GitHub Action에서 파일 이름을 조작하여 임의의 명령어를 실행할 수 있는 취약점이 발견되었습니다. 이 취약점을 이용하여 공격자는 GitHub Actions 워크플로우에서 임의의 명령어를 실행할 수 있습니다.

🇺🇸 원문 (English)

Super-linter is a combination of multiple linters to run as a GitHub Action or standalone. From 6.0.0 to 8.3.0, the Super-linter GitHub Action is vulnerable to command injection via crafted filenames. When this action is used in downstream GitHub Actions workflows, an attacker can submit a pull request that introduces a file whose name contains shell command substitution syntax, such as $(...). In affected Super-linter versions, runtime scripts may execute the embedded command during file discovery processing, enabling arbitrary command execution in the workflow runner context. This can be used to disclose the job’s GITHUB_TOKEN depending on how the workflow configures permissions. This vulnerability is fixed in 8.3.1.

📍 영향받는 시스템

Super-linter GitHub Action 6.0.0 ~ 8.3.0

⚔️ 공격 벡터

공격자는 pull request를 통해 특정 파일을 추가하여 임의의 명령어를 실행할 수 있습니다.

🛡️ 대응 방법

Super-linter GitHub Action을 8.3.1 이상으로 업데이트하세요.

🔧 검증 코드

로컬 Python 환경에서 pip를 사용하여 Super-linter의 버전을 확인합니다. Python과 pip가 설치되어 있어야 합니다.

Shell / Script
python -c "import subprocess; output = subprocess.check_output(['pip', 'show', 'super-linter']); version = output.decode('utf-8').split('\n')[1].split(': ')[1]; if version >= '8.3.1': print('{"result": "양호", "reason": "Super-linter 버전이 8.3.1 이상입니다."}') else: print('{"result": "취약", "reason": "Super-linter 버전이 8.3.1 미만입니다."}')"

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Git