🔍 CVE-2026-25892

7.5
CVSS Score
HIGH
2026-02-09
2026-02-10 15:22
✅ 완료

🇰🇷 한글 설명

Adminer v5.4.1 이하 버전에는 adminer.org에서 전달된 버전 정보를 처리하는 ?script=version 엔드포인트에 출처 검증이 없어, 임의의 출처에서 POST 데이터를 주입할 수 있습니다. 공격자가 version[] 파라미터를 배열로 전송하면 이후 페이지 로드 시 openssl_verify()에서 TypeError가 발생해 모든 사용자에게 HTTP 500 오류가 반환됩니다. 해결을 위해 Adminer 5.4.2 이상으로 업그레이드해야 합니다.

💡 쉬운 설명

데이터베이스 관리 도구 Adminer의 버전 확인 기능에 결함이 있어, 악의적인 요청으로 웹 페이지 전체가 오류를 일으키도록 만들 수 있습니다. 해당 도구를 최신 버전(5.4.2 이상)으로 업데이트하면 문제가 해결됩니다.

🇺🇸 원문 (English)

Adminer is open-source database management software. Adminer v5.4.1 and earlier has a version check mechanism where adminer.org sends signed version info via JavaScript postMessage, which the browser then POSTs to ?script=version. This endpoint lacks origin validation and accepts POST data from any source. An attacker can POST version[] parameter which PHP converts to an array. On next page load, openssl_verify() receives this array instead of string and throws TypeError, returning HTTP 500 to all users. Upgrade to Adminer 5.4.2.

📍 영향받는 시스템

Adminer 5.4.1 이하 버전을 사용하는 모든 시스템

⚔️ 공격 벡터

공격자가 Adminer의 ?script=version 엔드포인트에 version[] 배열 파라미터를 담아 POST 요청을 보내 TypeError와 HTTP 500 오류를 유발

🛡️ 대응 방법

Adminer를 5.4.2 이상 버전으로 업그레이드하고, 가능하면 관리 페이지를 외부 접근으로부터 제한

🔧 검증 코드

출력된 버전 번호가 5.4.2 미만이면 취약하므로 업그레이드가 필요하며, 아무 결과도 없으면 Adminer가 설치되어 있지 않은 것입니다.

Shell / Script
find / -name 'adminer*.php' 2>/dev/null -exec grep -H -m1 -E 'Adminer [0-9]+\.[0-9]+\.[0-9]+' {} \;

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

OpenSSL