🔍 CVE-2026-27124

6.1
CVSS Score
MEDIUM
2026-04-03
2026-07-24 22:10
✅ 완료

🇰🇷 한글 설명

FastMCP OAuthProxy가 GitHub OAuth 인증 코드 수신 시 사용자의 동의를 제대로 검증하지 않는 취약점입니다. GitHub의 이전 승인 클라이언트에 대한 동의 페이지 스킵 동작과 결합되면 Confused Deputy 공격이 가능하며, 버전 3.2.0에서 패치되었습니다.

💡 쉬운 설명

FastMCP의 GitHub 로그인 기능이 사용자의 실제 승인을 확인하지 않아 공격자가 다른 사람의 계정으로 로그인할 수 있습니다. GitHub이 이전에 승인한 앱의 경우 다시 묻지 않는 점을 악용할 수 있습니다.

🇺🇸 원문 (English)

FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, while testing the GitHubProvider OAuth integration, which allows authentication to a FastMCP MCP server via a FastMCP OAuthProxy using GitHub OAuth, it was discovered that the FastMCP OAuthProxy does not properly validate the user's consent upon receiving the authorization code from GitHub. In combination with GitHub’s behavior of skipping the consent page for previously authorized clients, this introduces a Confused Deputy vulnerability. This issue has been patched in version 3.2.0.

📍 영향받는 시스템

FastMCP 버전 3.2.0 미만 (GitHubProvider OAuth 통합 기능)

⚔️ 공격 벡터

인증 코드 위조/재사용 또는 Confused Deputy 공격을 통한 무단 OAuth 승인 우회

🛡️ 대응 방법

FastMCP를 버전 3.2.0 이상으로 업그레이드

🔧 검증 코드

표시된 버전이 3.2.0 이상이면 안전하고, 그 미만이면 즉시 업그레이드 필요합니다.

Shell / Script
pip show fastmcp | grep Version | awk '{print $2}'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

Git