🔍 CVE-2026-29170

6.1
CVSS Score
MEDIUM
2026-06-08
2026-07-23 07:10
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server 2.4.67 이하 버전의 mod_proxy_ftp 모듈에서 FTP 디렉토리 목록 생성 시 크로스 사이트 스크립팅(XSS) 취약점이 존재합니다. 이는 프록시 설정을 통해 FTP 디렉토리 내용을 나열할 때 발생하며, 공격자가 악성 스크립트를 삽입할 수 있게 합니다.

💡 쉬운 설명

웹 서버가 FTP 폴더 목록을 보여줄 때 해커가 악성 코드를 숨길 수 있는 구멍이 있습니다. 이 코드가 실행되면 사용자의 브라우저가 해커의 통제 아래에 놓일 수 있습니다.

🇺🇸 원문 (English)

A cross-site scripting vulnerability exists in mod_proxy_ftp's HTML directory list generation in Apache HTTP Server 2.4.67 and earlier when listing FTP directory contents either via forward or reverse proxy configuration. Users are recommended to upgrade to version 2.4.68, which fixes this issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.67 및 이전 버전

⚔️ 공격 벡터

악성 스크립트가 포함된 FTP 디렉토리 목록을 프록시를 통해 조회하도록 유도

🛡️ 대응 방법

보안이 강화된 Apache HTTP Server 2.4.68 이상으로 업그레이드하십시오.

🔧 검증 코드

출력된 버전 번호가 2.4.68 미만인 경우 취약한 것으로 판단합니다.

Shell / Script
httpd -v 2>/dev/null | grep -E 'version' || apachectl -v 2>/dev/null | grep -E 'version'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

Apache HTTP Server