🔍 CVE-2026-2996

7.5
CVSS Score
HIGH
2026-08-22
2026-10-12 16:10
✅ 완료

🇰🇷 한글 설명

WordPress용 Advanced Product Fields (Product Addons) for WooCommerce 플러그인의 'validate_cart_data' 함수에서 입력값 검증 미흡 취약점이 발견되었습니다. 이 논리적 결함으로 인해 인증되지 않은 공격자가 필수 유료 옵션을 우회하여 제품을 기본 가격으로만 구매할 수 있습니다. 이는 결과적으로 제품을 매우 저렴한 가격에 탈취하는 행위로 이어질 수 있습니다.

💡 쉬운 설명

쇼핑몰 플러그인의 오류를 이용해 추가 비용이 붙어야 하는 상품을 원래 가격 그대로 결제할 수 있는 문제입니다. 공격자는 유료 옵션을 건너뛰고 아주 적은 금액만 지불하여 물건을 훔칠 수 있습니다.

🇺🇸 원문 (English)

The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.

📍 영향받는 시스템

Advanced Product Fields (Product Addons) for WooCommerce 1.6.21 이하 모든 버전

⚔️ 공격 벡터

인증되지 않은 공격자가 장바구니 데이터 검증 로직을 우회하여 결제 프로세스 조작

🛡️ 대응 방법

플러그인을 최신 버전(1.6.21 이상 권장)으로 즉시 업데이트

🔧 검증 코드

명령어 결과에 나타나는 플러그인의 버전이 1.6.21보다 낮은지 확인하십시오.

Shell / Script
wp plugin list --status=active | grep -i 'advanced-product-fields'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

💻 영향받는 소프트웨어

WordPress