🇰🇷 한글 설명
Frappe는 풀스택 웹 애플리케이션 프레임워크입니다. 14.100.1, 15.100.0, 16.6.0 미만 버전에서 악의적인 사용자가 조작된 요청을 엔드포인트로 전송하여 서버가 사용자가 원하는 서비스로 HTTP 호출을 수행하게 만들 수 있습니다.
💡 쉬운 설명
해커가 조작된 요청을 보내 서버가 공격자가 원하는 곳으로 몰래 접속하게 만드는 취약점입니다. 이를 통해 서버를 이용해 다른 곳을 공격하거나 정보를 빼낼 수 있습니다.
🇺🇸 원문 (English)
Frappe is a full-stack web application framework. Prior to 14.100.1, 15.100.0, and 16.6.0, a malicious user could send a crafted request to an endpoint which would lead to the server making an HTTP call to a service of the user's choice. This vulnerability is fixed in 14.100.1, 15.100.0, and 16.6.0.
📍 영향받는 시스템
Frappe versions prior to 14.100.1, 15.100.0, and 16.6.0
⚔️ 공격 벡터
조작된 HTTP 요청을 통한 서버 측 요청 위조 (SSRF)
🛡️ 대응 방법
Frappe를 14.100.1, 15.100.0 또는 16.6.0 이상의 버전으로 업데이트하십시오.
🔧 검증 코드
출력된 Frappe 버전이 14.100.1, 15.100.0, 16.6.0보다 낮은지 확인하십시오.
bench version | grep -E 'frappe (14\.[0-9]+|15\.[0-9]+|16\.[0-9]+)'
📊 CVSS Vector String
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
💻 영향받는 소프트웨어
IBM WebSphere Application Server