🇰🇷 한글 설명
Apache Tomcat에서 CVE-2025-66614의 불완전한 수정으로 인해 발생한 입력 유효성 검사 취약점입니다. Apache Tomcat 11.0.15~11.0.19, 10.1.50~10.1.52, 9.0.113~9.0.115 버전이 영향을 받습니다. 11.0.20, 10.1.53, 9.0.116 이상 버전으로 업그레이드하면 해결됩니다.
💡 쉬운 설명
웹 서버 소프트웨어인 Apache Tomcat에서 이전에 수정했던 보안 문제가 완전히 고쳐지지 않아 다시 취약점이 발생했습니다. 공격자가 잘못된 입력값을 보내 예상치 못한 동작을 유발할 수 있습니다.
🇺🇸 원문 (English)
Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614.
This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115.
Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
📍 영향받는 시스템
Apache Tomcat 11.0.15~11.0.19, 10.1.50~10.1.52, 9.0.113~9.0.115
⚔️ 공격 벡터
원격 공격자가 조작된 HTTP 요청(비정상적인 입력값)을 전송하여 입력 유효성 검사를 우회
🛡️ 대응 방법
Apache Tomcat 11.0.20, 10.1.53, 또는 9.0.116 이상 버전으로 즉시 업그레이드
🔧 검증 코드
출력된 Implementation-Version 값이 11.0.20, 10.1.53, 9.0.116 미만이면 취약한 버전이므로 업그레이드 필요
find /opt /usr/local /usr/share -name 'catalina.jar' 2>/dev/null -exec unzip -p {} META-INF/MANIFEST.MF \; 2>/dev/null | grep -i 'Implementation-Version\|Specification-Version'