🔍 CVE-2026-3328

7.2
CVSS Score
HIGH
2026-03-26
2026-04-24 16:35
✅ 완료

🇰🇷 한글 설명

WordPress Frontend Admin by DynamiApps 플러그인의 버전 3.28.31 이하에서 admin_form 포스트의 post_content 역직렬화 시 PHP Object Injection 취약점이 존재합니다. WordPress의 maybe_unserialize() 함수가 사용자 제어 가능 콘텐츠에 대해 클래스 제한 없이 사용되어 인증된 Editor 이상 권한의 공격자가 PHP 객체를 주입하고 POP 체인을 이용한 원격 코드 실행이 가능합니다.

💡 쉬운 설명

WordPress 플러그인이 사용자 데이터를 안전하지 않게 처리하여, 충분한 권한의 악의적 사용자가 악성 코드를 실행할 수 있습니다. 플러그인을 최신 버전으로 업데이트하면 문제가 해결됩니다.

🇺🇸 원문 (English)

The Frontend Admin by DynamiApps plugin for WordPress is vulnerable to PHP Object Injection via deserialization of the 'post_content' of admin_form posts in all versions up to, and including, 3.28.31. This is due to the use of WordPress's `maybe_unserialize()` function without class restrictions on user-controllable content stored in admin_form post content. This makes it possible for authenticated attackers, with Editor-level access and above, to inject a PHP Object. The additional presence of a POP chain allows attackers to achieve remote code execution.

📍 영향받는 시스템

Frontend Admin by DynamiApps plugin for WordPress versions up to and including 3.28.31

⚔️ 공격 벡터

Authenticated attackers with Editor-level access or above inject malicious PHP objects via admin_form post content deserialization

🛡️ 대응 방법

Update Frontend Admin by DynamiApps plugin to a patched version beyond 3.28.31

🔧 검증 코드

플러그인이 설치되어 있으면 경로가 출력됨; 출력 없으면 플러그인 미설치

Shell / Script
grep -r 'Frontend Admin' /var/www/html/wp-content/plugins/ 2>/dev/null | head -1

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP