🔍 CVE-2026-33508

7.5
CVSS Score
HIGH
2026-03-24
2026-06-17 10:37
✅ 완료

🇰🇷 한글 설명

Parse Server의 LiveQuery 구성 요소가 WebSocket 구독 요청을 처리할 때 requestComplexity.queryDepth 설정을 강제하지 않는 취약점이 발견되었습니다. 공격자가 깊게 중첩된 논리 연산자를 포함한 구독 요청을 보내면 과도한 재귀 호출과 CPU 소비를 유발하여 서비스 가용성을 저하시키거나 중단시킬 수 있습니다.

💡 쉬운 설명

서버에 너무 복잡하고 깊은 질문을 던져서 서버의 계산 능력을 바닥나게 만드는 공격입니다. 이로 인해 서버가 과부하에 걸려 정상적인 서비스 이용이 어려워질 수 있습니다.

🇺🇸 원문 (English)

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.56 and 9.6.0-alpha.45, Parse Server's LiveQuery component does not enforce the requestComplexity.queryDepth configuration setting when processing WebSocket subscription requests. An attacker can send a subscription with deeply nested logical operators, causing excessive recursion and CPU consumption that degrades or disrupts service availability. This issue has been patched in versions 8.6.56 and 9.6.0-alpha.45.

📍 영향받는 시스템

Parse Server 8.6.56 미만 버전 및 9.6.0-alpha.45 미만 버전

⚔️ 공격 벡터

WebSocket을 통한 깊게 중첩된 논리 연산자 포함 구독 요청 전송

🛡️ 대응 방법

Parse Server를 8.6.56 또는 9.6.0-alpha.45 이상의 버전으로 업데이트하십시오.

🔧 검증 코드

출력된 parse-server의 버전이 8.6.56 또는 9.6.0-alpha.45 이상인지 확인합니다.

Shell / Script
npm list parse-server

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Node.js