🔍 CVE-2026-33857

5.3
CVSS Score
MEDIUM
2026-05-04
2026-10-26 19:10
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server의 mod_proxy_ajp 모듈에서 발생하는 범위 초과 읽기(Out-of-bounds Read) 취약점입니다. 2.4.66 이하 버전에 영향을 미치며 메모리 정보 유출을 야기할 수 있습니다. 버전 2.4.67로 업그레이드하여 해결합니다.

💡 쉬운 설명

Apache 웹 서버의 AJP 프록시 기능에서 메모리를 잘못 읽을 수 있는 보안 결함입니다. 공격자가 이를 악용해 서버의 민감한 정보를 유출할 수 있습니다.

🇺🇸 원문 (English)

Out-of-bounds Read vulnerability in mod_proxy_ajp of Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.66 이하

⚔️ 공격 벡터

조작된 AJP 프록시 요청을 통한 범위 초과 메모리 읽기

🛡️ 대응 방법

Apache HTTP Server를 2.4.67 이상으로 즉시 업그레이드

🔧 검증 코드

현재 설치된 Apache 버전을 확인하여 2.4.67 이상이면 패치됨, 2.4.66 이하면 취약함을 의미합니다.

Shell / Script
apache2ctl -v 2>/dev/null | grep -oP 'Apache/\K[0-9.]+' || httpd -v 2>/dev/null | grep -oP 'Apache/\K[0-9.]+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

💻 영향받는 소프트웨어

Apache HTTP Server