🔍 CVE-2026-34032

5.3
CVSS Score
MEDIUM
2026-05-04
2026-10-26 19:10
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server 2.4.66 이하 버전에서 발생하는 부적절한 null 종료 및 범위 벗어난 읽기 취약점입니다. 이 결함을 통해 원격 공격자가 메모리 영역에 접근하여 서버 정보를 유출하거나 서비스 거부 상태를 야기할 수 있습니다.

💡 쉬운 설명

Apache 웹 서버의 메모리 처리 결함으로, 공격자가 메모리의 허가되지 않은 영역을 읽을 수 있게 됩니다. 이는 민감한 정보 유출 또는 서버 장애를 초래할 수 있습니다.

🇺🇸 원문 (English)

Improper Null Termination, Out-of-bounds Read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

📍 영향받는 시스템

Apache HTTP Server 버전 2.4.66 이하 (Linux, Windows, macOS 등 모든 플랫폼)

⚔️ 공격 벡터

특수한 요청을 통한 네트워크 기반 원격 공격 가능

🛡️ 대응 방법

Apache HTTP Server를 2.4.67 이상으로 즉시 업그레이드

🔧 검증 코드

출력된 버전 번호가 2.4.67 이상이면 안전, 2.4.66 이하면 취약

Shell / Script
apache2 -v 2>/dev/null | grep -oE 'Apache/[0-9]+\.[0-9]+\.[0-9]+' || httpd -v 2>/dev/null | grep -oE 'Apache/[0-9]+\.[0-9]+\.[0-9]+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

💻 영향받는 소프트웨어

Apache HTTP Server