🔍 CVE-2026-34059

7.5
CVSS Score
HIGH
2026-05-04
2026-10-26 19:10
✅ 완료

🇰🇷 한글 설명

Apache HTTP Server의 버퍼 오버리드 취약점으로, 공격자가 메모리 범위를 초과하여 데이터를 읽을 수 있습니다. 이를 통해 정보 유출 및 서비스 거부 공격이 가능합니다.

💡 쉬운 설명

웹 서버의 메모리를 잘못된 방식으로 읽을 수 있는 버그입니다. 공격자가 악용하면 중요한 정보가 노출되거나 서버가 중단될 수 있습니다.

🇺🇸 원문 (English)

Buffer Over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

📍 영향받는 시스템

Apache HTTP Server 2.4.66 이하 모든 버전

⚔️ 공격 벡터

네트워크를 통한 원격 공격 (HTTP 요청으로 버퍼 오버리드 트리거 가능)

🛡️ 대응 방법

Apache HTTP Server를 2.4.67 이상으로 즉시 업그레이드

🔧 검증 코드

출력된 Apache 버전이 2.4.67 이상이면 안전, 2.4.66 이하면 취약점 존재

Shell / Script
apachectl -v 2>/dev/null | grep -oP '(?<=Server version: Apache/)[0-9.]+'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

💻 영향받는 소프트웨어

Apache HTTP Server