🔍 CVE-2026-34501

7.5
CVSS Score
HIGH
2026-08-06
2026-10-24 16:10
✅ 완료

🇰🇷 한글 설명

Apache Portable Runtime Utility의 redis 클라이언트에서 힙 기반 버퍼 오버플로우 취약점이 발견되었습니다. 이 문제는 1.6.0 버전부터 1.6.3 버전까지의 사용자에게 영향을 미칩니다.

💡 쉬운 설명

프로그램이 데이터를 저장하는 메모리 공간을 넘쳐흐르게 만들어 시스템을 오작동하게 만들 수 있는 결함입니다. 해커가 이를 이용해 컴퓨터를 제어하거나 정보를 훔칠 위험이 있습니다.

🇺🇸 원문 (English)

Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

📍 영향받는 시스템

Apache Portable Runtime Utility 1.6.0 ~ 1.6.3

⚔️ 공격 벡터

조작된 데이터를 redis 클라이언트로 전송하여 메모리 영역을 침범하는 방식

🛡️ 대응 방법

Apache Portable Runtime Utility를 1.6.4 버전 이상으로 업그레이드

🔧 검증 코드

출력된 결과에서 aprutil의 버전을 확인하여 1.6.4 미만인지 체크합니다.

Shell / Script
dpkg -l | grep aprutil 2>/dev/null || rpm -qa | grep aprutil 2>/dev/null

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Redis