🔍 CVE-2026-34577

8.6
CVSS Score
HIGH
2026-04-02
2026-07-24 21:10
✅ 완료

🇰🇷 한글 설명

AI 소셜 미디어 스케줄링 도구인 Postiz의 2.21.3 미만 버전에서 발생하는 SSRF 취약점입니다. PublicController의 GET /public/stream 엔드포인트가 URL 검증을 부실하게 수행하여, 인증되지 않은 공격자가 내부 서비스나 클라우드 메타데이터에 접근할 수 있습니다.

💡 쉬운 설명

공격자가 조작된 주소를 입력하여 서비스 내부의 비밀 정보나 네트워크 자원을 몰래 훔쳐볼 수 있는 보안 결함입니다. 주소 끝에 특정 확장자만 붙이면 검사를 쉽게 통과할 수 있어 위험합니다.

🇺🇸 원문 (English)

Postiz is an AI social media scheduling tool. Prior to version 2.21.3, the GET /public/stream endpoint in PublicController accepts a user-supplied url query parameter and proxies the full HTTP response back to the caller. The only validation is url.endsWith('mp4'), which is trivially bypassable by appending .mp4 as a query parameter value or URL fragment. The endpoint requires no authentication and has no SSRF protections, allowing an unauthenticated attacker to read responses from internal services, cloud metadata endpoints, and other network-internal resources. This issue has been patched in version 2.21.3.

📍 영향받는 시스템

Postiz version < 2.21.3

⚔️ 공격 벡터

인증 없이 /public/stream 엔드포인트에 조작된 URL 파라미터를 전달하여 내부 네트워크 자원에 접근

🛡️ 대응 방법

Postiz를 최신 보안 패치가 적용된 버전인 2.21.3 이상으로 업데이트하십시오.

🔧 검증 코드

명령어 결과에 2.21.3 이상의 버전 번호가 출력되면 취약점이 해결된 상태입니다.

Shell / Script
curl -s http://<target-ip>/version | grep -E '2.21.3'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

💻 영향받는 소프트웨어

Cloud Services