🇰🇷 한글 설명
vLLM 0.16.0 버전부터 0.19.0 미만 버전에서 발생하는 서버 측 요청 위조(SSRF) 취약점입니다. 공격자가 배치 입력 JSON을 제어할 수 있다면 URL 검증 부재를 악용하여 서버가 임의의 HTTP/HTTPS 요청을 보내도록 유도할 수 있습니다. 이를 통해 클라우드 메타데이터 엔드포인트나 내부 API와 같은 내부 서비스가 공격 대상이 될 수 있습니다.
💡 쉬운 설명
해커가 vLLM 서버에 특수한 명령을 보내 서버가 스스로 내부 네트워크의 다른 컴퓨터에 접속하게 만드는 공격입니다. 이를 통해 서버 내부의 중요한 정보나 관리자 페이지에 몰래 접근할 수 있습니다.
🇺🇸 원문 (English)
vLLM is an inference and serving engine for large language models (LLMs). From 0.16.0 to before 0.19.0, a server-side request forgery (SSRF) vulnerability in download_bytes_from_url allows any actor who can control batch input JSON to make the vLLM batch runner issue arbitrary HTTP/HTTPS requests from the server, without any URL validation or domain restrictions.
This can be used to target internal services (e.g. cloud metadata endpoints or internal HTTP APIs) reachable from the vLLM host. This vulnerability is fixed in 0.19.0.
📍 영향받는 시스템
vLLM versions 0.16.0 to < 0.19.0
⚔️ 공격 벡터
배치 입력 JSON 데이터를 조작하여 download_bytes_from_url 함수에 임의의 URL을 주입
🛡️ 대응 방법
vLLM 버전을 0.19.0 이상으로 업데이트
🔧 검증 코드
출력된 버전이 0.19.0 미만(0.16.x ~ 0.18.x)이면 취약한 상태입니다.
pip show vllm | grep Version