🔍 CVE-2026-35029

8.8
CVSS Score
HIGH
2026-04-06
2026-10-23 23:10
✅ 완료

🇰🇷 한글 설명

LiteLLM 프록시 서버의 /config/update 엔드포인트가 관리자 권한 검증을 하지 않아, 인증된 사용자가 설정 및 환경 변수를 수정할 수 있습니다. 이를 통해 공격자는 악의적 Python 코드 실행, 임의 파일 읽기, 관리자 계정 탈취 등의 공격을 수행할 수 있습니다. v1.83.0에서 수정되었습니다.

💡 쉬운 설명

LiteLLM 서버의 설정 변경 기능이 누구든지 사용 가능해서, 로그인한 사용자라면 누구든 서버를 완전히 제어할 수 있습니다. 관리자 계정 탈취, 악성 코드 실행, 민감 파일 접근이 모두 가능합니다.

🇺🇸 원문 (English)

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.

📍 영향받는 시스템

LiteLLM < v1.83.0

⚔️ 공격 벡터

인증된 사용자가 /config/update 엔드포인트에 악의적 환경변수(UI_LOGO_PATH, UI_PASSWORD 등) 또는 Python 코드를 포함한 설정을 전송

🛡️ 대응 방법

LiteLLM를 v1.83.0 이상으로 즉시 업그레이드

🔧 검증 코드

설치된 버전이 1.83.0 이상이면 안전함, 1.83.0 미만이면 긴급 업그레이드 필요

Shell / Script
python -c "import litellm; print(litellm.__version__)" 2>/dev/null || pip show litellm | grep Version

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Python