🔍 CVE-2026-3520

7.5
CVSS Score
HIGH
2026-03-04
2026-07-15 02:21
✅ 완료

🇰🇷 한글 설명

Multer 2.1.1 미만 버전에서 발생하는 취약점으로, 공격자가 조작된 요청을 전송하여 스택 오버플로우를 유발하고 서비스 거부(DoS) 상태를 만들 수 있습니다. 이 취약점을 방지하기 위해서는 반드시 2.1.1 버전 이상으로 업그레이드해야 합니다.

💡 쉬운 설명

파일 업로드를 도와주는 프로그램에 결함이 있어, 나쁜 의도를 가진 요청을 보내면 서버가 멈춰버릴 수 있습니다. 서버가 정상적으로 작동하도록 프로그램을 최신 버전으로 업데이트해야 합니다.

🇺🇸 원문 (English)

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.

📍 영향받는 시스템

Multer version < 2.1.1

⚔️ 공격 벡터

조작된 multipart/form-data 요청을 통한 스택 오버플로우 유발

🛡️ 대응 방법

Multer를 버전 2.1.1 이상으로 업데이트

🔧 검증 코드

출력된 버전 번호가 2.1.1 미만인지 확인합니다.

Shell / Script
npm list multer | grep multer

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Node.js