🔍 CVE-2026-35204

8.6
CVSS Score
HIGH
2026-04-09
2026-07-15 02:20
✅ 완료

🇰🇷 한글 설명

Kubernetes 패키지 관리자 Helm의 4.0.0~4.1.3 버전에서 악의적으로 제작된 플러그인의 plugin.yaml 파일에 포함된 경로 이동(/../) 문자열을 통해 임의의 파일시스템 위치에 플러그인 내용을 쓸 수 있는 취약점이 존재한다. 공격자가 중요한 시스템 파일을 덮어쓰거나 권한을 상승시킬 수 있으며, 4.1.4 버전에서 수정되었다.

💡 쉬운 설명

Helm 도구에서 나쁜 의도의 플러그인을 설치하면 해커가 서버의 임의의 위치에 파일을 저장할 수 있습니다. 이를 통해 중요한 시스템 파일을 손상시키거나 권한을 탈취할 수 있습니다.

🇺🇸 원문 (English)

Helm is a package manager for Charts for Kubernetes. From 4.0.0 to 4.1.3, a specially crafted Helm plugin, when installed or updated, will cause Helm to write the contents of the plugin to an arbitrary filesystem location. To prevent this, validate that the plugin.yaml of the Helm plugin does not include a version: field containing POSIX dot-dot path separators ie. "/../". This vulnerability is fixed in 4.1.4.

📍 영향받는 시스템

Helm 4.0.0 ~ 4.1.3

⚔️ 공격 벡터

plugin.yaml의 version 필드에 경로 이동 문자(/../)를 포함한 악의적 플러그인을 설치/업데이트하여 임의 위치에 파일 작성

🛡️ 대응 방법

Helm을 4.1.4 이상으로 즉시 업그레이드하고 신뢰할 수 없는 플러그인 설치 금지

🔧 검증 코드

버전이 4.1.4 이상이면 안전, 4.0.0~4.1.3 사이면 취약점 존재

Shell / Script
helm version 2>/dev/null | grep -o 'v[0-9]*\.[0-9]*\.[0-9]*' | head -1

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

💻 영향받는 소프트웨어

Kubernetes