🇰🇷 한글 설명
Helm 4.0.0부터 4.1.3 버전에서 서명 검증이 필수인 경우에도 provenance 파일(.prov)이 없는 플러그인을 설치하는 취약점이 있습니다. 이는 검증되지 않은 악의적 플러그인이 쿠버네티스 시스템에 설치될 수 있음을 의미하며, 4.1.4 버전에서 수정되었습니다.
💡 쉬운 설명
Helm은 쿠버네티스에 소프트웨어를 설치하는 도구인데, 4.0.0~4.1.3 버전에서는 검증 절차를 건너뛰고 플러그인을 설치할 수 있습니다. 공격자가 악의적인 플러그인을 제공하면 시스템이 감염될 수 있습니다.
🇺🇸 원문 (English)
Helm is a package manager for Charts for Kubernetes. From 4.0.0 to 4.1.3, Helm will install plugins missing provenance (.prov file) when signature verification is required. This vulnerability is fixed in 4.1.4.
📍 영향받는 시스템
Helm 4.0.0 ~ 4.1.3 버전
⚔️ 공격 벡터
악의적인 플러그인을 제공하여 Helm의 서명 검증 메커니즘을 우회하도록 유도
🛡️ 대응 방법
Helm을 4.1.4 이상으로 즉시 업그레이드
🔧 검증 코드
명령어 결과로 v4.0.x 또는 v4.1.0~4.1.3 버전이 표시되면 취약점이 있습니다.
helm version --short 2>/dev/null | grep -E '^v4\.(0|1\.[0-3])'