🇰🇷 한글 설명
xrdp는 오픈소스 RDP 서버이며, 0.10.5 이하 버전에서 EGFX(그래픽 동적 가상 채널) 구현의 힙 기반 버퍼 오버플로우 취약점이 존재합니다. 클라이언트가 제어하는 크기 파라미터에 대한 검증이 부족하여, 조작된 PDU를 통해 범위를 벗어난 쓰기가 발생할 수 있습니다. 인증 이전 공격은 프로세스 충돌을 일으킬 수 있고, 인증 이후 공격은 원격 코드 실행으로 이어질 수 있으며, 0.10.6 버전에서 수정되었습니다.
💡 쉬운 설명
원격 데스크톱 서버(xrdp)가 외부에서 조작된 데이터를 받으면 메모리가 넘쳐 서버가 멈추거나 공격자가 임의의 명령을 실행할 수 있습니다. 즉시 업데이트할 수 없다면 권한이 낮은 사용자로 xrdp를 실행해 피해 범위를 줄이세요.
🇺🇸 원문 (English)
xrdp is an open source RDP server. Versions through 0.10.5 have a heap-based buffer overflow in the EGFX (graphics dynamic virtual channel) implementation due to insufficient validation of client-controlled size parameters, allowing an out-of-bounds write via crafted PDUs. Pre-authentication exploitation can crash the process, while post-authentication exploitation may achieve remote code execution. This issue has been fixed in version 0.10.6. If users are unable to immediately update, they should run xrdp as a non-privileged user (default since 0.10.2) to limit the impact of successful exploitation.
📍 영향받는 시스템
xrdp 0.10.5 이하 버전 (0.10.6에서 수정됨)
⚔️ 공격 벡터
네트워크를 통해 조작된 EGFX PDU를 전송하여 힙 버퍼 오버플로우를 유발 (인증 전 DoS, 인증 후 원격 코드 실행 가능)
🛡️ 대응 방법
xrdp를 0.10.6 이상으로 업데이트하고, 업데이트가 어려운 경우 비특권 사용자로 xrdp를 실행
🔧 검증 코드
출력된 버전이 0.10.6 미만이면 취약하며, 0.10.6 이상이면 패치가 적용된 것입니다.
xrdp --version 2>/dev/null || dpkg -l xrdp 2>/dev/null | grep xrdp