🔍 CVE-2026-40048

7.8
CVSS Score
HIGH
2026-04-27
2026-10-26 22:10
✅ 완료

🇰🇷 한글 설명

Apache Camel의 Camel-PQC FileBasedKeyLifecycleManager 클래스는 키 디렉터리의 `<keyId>.key` 파일을 ObjectInputFilter나 클래스 로딩 제한 없이 ObjectInputStream으로 역직렬화합니다. KeyPair 타입 검사가 readObject() 이후에 수행되므로, 공격자가 조작된 직렬화 객체를 키 디렉터리에 배치하면 타입 검사 전에 임의 코드가 실행될 수 있습니다. 4.19.0 이상 4.20.0 미만, 4.18.0 이상 4.18.2 미만 버전이 영향을 받습니다.

💡 쉬운 설명

키 저장 폴더에 악성 파일을 몰래 넣을 수 있다면, 프로그램이 그 파일을 읽는 순간 공격자가 원하는 명령이 실행될 수 있습니다. 해결하려면 최신 버전으로 업데이트해야 합니다.

🇺🇸 원문 (English)

The Camel-PQC FileBasedKeyLifecycleManager class deserializes the contents of `<keyId>.key` files in the configured key directory using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. The cast to `java.security.KeyPair` is evaluated only after `readObject()` has already returned, so any `readObject()` side effects in the deserialized object run before the type check. An attacker who can write to the key directory used by a Camel application — for example through a path traversal into the directory, misconfigured filesystem permissions on the volume where keys are stored, a compromised key provisioning pipeline, or a symlink attack — can place a crafted serialized Java object that, when deserialized during normal key lifecycle operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.19.0 before 4.20.0, from 4.18.0 before 4.18.2. Users are recommended to upgrade to version 4.20.0, which fixes the issue by replacing java.io.ObjectInputStream-based key and metadata storage with standard PKCS#8 (private key) / X.509 SubjectPublicKeyInfo (public key) Base64 JSON encoding. For users on the 4.18.x LTS releases stream, upgrade to 4.18.2.

📍 영향받는 시스템

Apache Camel 4.19.0~4.20.0 미만, 4.18.0~4.18.2 미만 (Camel-PQC 모듈 사용 환경)

⚔️ 공격 벡터

경로 순회, 잘못된 파일 권한, 심볼릭 링크, 침해된 키 배포 파이프라인을 통해 키 디렉터리에 악성 직렬화 객체를 기록

🛡️ 대응 방법

Apache Camel 4.20.0 이상으로 업그레이드 (4.18.x LTS 사용자는 4.18.2 이상으로 업그레이드)

🔧 검증 코드

출력된 Implementation-Version이 4.19.0 이상 4.20.0 미만 또는 4.18.0 이상 4.18.2 미만이면 취약하므로 업그레이드가 필요하며, 4.20.0 이상이거나 4.18.2 이상이면 조치가 완료된 것입니다.

Shell / Script
grep -rl 'apache-camel' --include='*.jar' . 2>/dev/null | xargs -I{} unzip -p {} META-INF/MANIFEST.MF 2>/dev/null | grep -i 'Implementation-Version'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Oracle Java SE