🇰🇷 한글 설명
Math.js 라이브러리의 표현식 파서에서 임의의 JavaScript 코드 실행 취약점이 존재합니다. 버전 13.1.0부터 15.2.0 이전까지 영향을 받으며, 악의적인 수식 입력을 통해 공격자가 시스템 명령을 실행할 수 있습니다. 버전 15.2.0 이상으로 업그레이드하여 해결됩니다.
💡 쉬운 설명
Math.js 계산 라이브러리에서 나쁜 수식을 넣으면 컴퓨터가 해커의 명령을 실행할 수 있습니다. 이 라이브러리를 사용하는 모든 애플리케이션이 위험에 빠질 수 있습니다.
🇺🇸 원문 (English)
Math.js is an extensive math library for JavaScript and Node.js. From version 13.1.0 to before version 15.2.0, arbitrary JavaScript can be executed via the expression parser of mathjs. This issue has been patched in version 15.2.0.
📍 영향받는 시스템
Math.js 13.1.0 ~ 15.1.x (Node.js 및 JavaScript 환경)
⚔️ 공격 벡터
애플리케이션에 제공되는 사용자 입력 수식을 표현식 파서로 처리할 때 악의적 코드 주입
🛡️ 대응 방법
Math.js 패키지를 버전 15.2.0 이상으로 업그레이드 (npm update mathjs)
🔧 검증 코드
출력된 버전 번호가 15.2.0 이상이면 안전, 13.1.0 이상 15.2.0 미만이면 즉시 업그레이드 필요
npm list mathjs 2>&1 | grep -E 'mathjs@[0-9]' | head -1