🔍 CVE-2026-41143

8.8
CVSS Score
HIGH
2026-05-07
2026-05-07 15:43
✅ 완료

🇰🇷 한글 설명

YesWiki는 PHP로 작성된 위키 시스템으로, 4.6.1 이전 버전의 bazar 모듈에서 EntryManager.php 704번 줄에 SQL 인젝션 취약점이 존재합니다. $_POST['id_fiche']에서 가져온 값이 검증 없이 SQL 쿼리에 직접 연결되어 인증 없는 공격자도 데이터베이스 명령을 실행할 수 있습니다. 4.6.1 버전에서 패치되었습니다.

💡 쉬운 설명

YesWiki라는 웹 기반 노트 서비스에서 사용자 입력을 제대로 검증하지 않아 악의적인 명령으로 데이터베이스를 조작할 수 있는 문제가 있습니다. 이를 통해 정보 유출, 변조, 삭제 등 심각한 피해가 발생할 수 있습니다.

🇺🇸 원문 (English)

YesWiki is a wiki system written in PHP. Prior to version 4.6.1, YesWiki bazar module contains a SQL injection vulnerability in tools/bazar/services/EntryManager.php at line 704. The $data['id_fiche'] value (sourced from $_POST['id_fiche']) is concatenated directly into a raw SQL query without any sanitization or parameterization. This issue has been patched in version 4.6.1.

📍 영향받는 시스템

YesWiki < 4.6.1 (PHP 기반 위키 시스템)

⚔️ 공격 벡터

HTTP POST 요청의 id_fiche 매개변수에 SQL 페이로드를 삽입하여 데이터베이스 직접 조작

🛡️ 대응 방법

YesWiki를 4.6.1 이상으로 즉시 업그레이드하거나 EntryManager.php의 쿼리를 파라미터화된 준비된 명령문으로 변경

🔧 검증 코드

설치된 YesWiki 버전을 확인하여 4.6.1 미만이면 취약점 존재, 4.6.1 이상이면 안전

Shell / Script
grep -r "version.*4\.6" /var/www/*/index.php 2>/dev/null | grep -E '4\.(0|1|2|3|4|5|6)\.' && echo 'Vulnerable version found' || echo 'Version OK or not found'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

PHP