🔍 CVE-2026-41496

8.1
CVSS Score
HIGH
2026-05-08
2026-10-26 19:10
✅ 완료

🇰🇷 한글 설명

PraisonAI의 데이터베이스 백엔드들에 SQL 인젝션 취약점이 광범위하게 존재합니다. CVE-2026-40315의 SQLite 전용 패치 이후 MySQL, PostgreSQL, Turso, SingleStore, Supabase, SurrealDB 등 9개 형제 백엔드에서 table_prefix 파라미터가 유효성 검사 없이 SQL 문에 직접 삽입되고 있습니다. 총 52개의 검증되지 않은 인젝션 지점이 있으며, postgres.py는 추가로 DDL에서 검증되지 않은 schema 파라미터를 받습니다.

💡 쉬운 설명

PraisonAI 프로그램이 데이터베이스에 저장된 정보를 접근할 때 사용자 입력을 제대로 확인하지 않아서, 공격자가 임의로 데이터베이스를 조작할 수 있습니다. 여러 종류의 데이터베이스(MySQL, PostgreSQL 등)가 모두 같은 방식으로 공격받을 수 있습니다.

🇺🇸 원문 (English)

PraisonAI is a multi-agent teams system. Prior to praisonai version 4.6.9 and praisonaiagents version 1.6.9, the fix for CVE-2026-40315 added input validation to SQLiteConversationStore only. Nine sibling backends — MySQL, PostgreSQL, async SQLite/MySQL/PostgreSQL, Turso, SingleStore, Supabase, SurrealDB — pass table_prefix straight into f-string SQL. Same root cause, same code pattern, same exploitation. 52 unvalidated injection points across the codebase. postgres.py additionally accepts an unvalidated schema parameter used directly in DDL. This issue has been patched in praisonai version 4.6.9 and praisonaiagents version 1.6.9.

📍 영향받는 시스템

praisonai < 4.6.9, praisonaiagents < 1.6.9 (MySQL, PostgreSQL, Turso, SingleStore, Supabase, SurrealDB, async 변형 포함)

⚔️ 공격 벡터

공격자가 table_prefix 또는 schema 파라미터에 SQL 구문을 주입하여 인증 우회, 데이터 탈취, 무단 수정/삭제 가능

🛡️ 대응 방법

praisonai를 4.6.9 이상, praisonaiagents를 1.6.9 이상으로 업그레이드

🔧 검증 코드

설치된 버전이 4.6.9 이상이면 안전함. 4.6.9 미만이거나 'Not installed' 메시지가 나타나면 업그레이드 필요

Shell / Script
python -c "import praisonai; print(f'Version: {praisonai.__version__}')" 2>/dev/null || pip show praisonai 2>/dev/null | grep Version || echo "Not installed"

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

💻 영향받는 소프트웨어

MySQL