🔍 CVE-2026-41636

7.5
CVSS Score
HIGH
2026-04-28
2026-10-26 21:10
✅ 완료

🇰🇷 한글 설명

Apache Thrift Node.js 바인딩의 제어되지 않는 재귀 취약점으로, 악의적인 입력 처리 시 스택 오버플로우를 통한 서비스 거부(DoS) 공격이 가능합니다. 버전 0.23.0 이전의 모든 Apache Thrift에 영향을 미칩니다.

💡 쉬운 설명

Apache Thrift는 프로그램 간 통신용 소프트웨어인데, Node.js 버전에서 특정 형태의 데이터를 받으면 무한 반복되어 서비스가 중단될 수 있습니다. 공격자가 의도적으로 이를 악용하여 서비스를 마비시킬 수 있습니다.

🇺🇸 원문 (English)

Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

📍 영향받는 시스템

Apache Thrift < 0.23.0 (Node.js bindings)

⚔️ 공격 벡터

Maliciously crafted recursive data structures sent to Apache Thrift Node.js services causing stack overflow

🛡️ 대응 방법

Upgrade Apache Thrift to version 0.23.0 or later in package.json and run npm install

🔧 검증 코드

출력에서 apache-thrift 버전이 0.23.0 이상이면 패치됨, 0.23.0 미만이면 즉시 업그레이드 필요

Shell / Script
npm list 2>/dev/null | grep -i apache-thrift || cat package.json | grep -A 1 'apache-thrift'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

💻 영향받는 소프트웨어

Node.js