🇰🇷 한글 설명
Apache APISIX의 wolf-rbac 플러그인 기본 설정에서 신뢰할 수 없는 소스를 사용하는 취약점이 발견되었습니다. 공격자는 이를 통해 로그에 위조된 신원 정보를 삽입하거나 IP 기반의 접근 제어 규칙을 우회할 수 있습니다.
💡 쉬운 설명
공격자가 가짜 정보를 사용하여 시스템 로그를 조작하거나, IP 주소를 속여 허가되지 않은 접근을 시도할 수 있는 문제입니다. 보안 설정이 허술한 부분을 이용해 시스템의 출입 통제 규칙을 무력화할 수 있습니다.
🇺🇸 원문 (English)
Use of Less Trusted Source vulnerability in Apache APISIX.
Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules.
This issue affects Apache APISIX: from 1.2.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
📍 영향받는 시스템
Apache APISIX 1.2.0 ~ 3.16.0 버전
⚔️ 공격 벡터
wolf-rbac 플러그인의 기본 설정을 악용하여 위조된 신원 정보로 로그를 오염시키거나 IP 기반 접근 제어를 우회함
🛡️ 대응 방법
Apache APISIX를 취약점이 해결된 3.17.0 버전 이상으로 업그레이드하십시오.
🔧 검증 코드
명령어 실행 결과 버전이 3.17.0 이상으로 출력되면 취약점이 해결된 상태입니다.
apix-cli --version 2>/dev/null || apache-apisix --version 2>/dev/null | grep -E '3\.(1[7-9]|[2-9][0-9])\\.'
📊 CVSS Vector String
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
💻 영향받는 소프트웨어
IBM Verify Identity Access