🇰🇷 한글 설명
Apache HTTP Server는 공격자가 통제하는 OCSP 서버와의 아웃바운드 OCSP 요청 처리 중 버퍼 오버리드 취약점이 있습니다. 이 취약점은 2.4.0부터 2.4.67 버전까지 영향을 미치며, 2.4.68 버전으로 업그레이드하여 해결해야 합니다.
💡 쉬운 설명
웹 서버가 보안 인증 정보를 확인하는 과정에서 외부 서버의 잘못된 데이터로 인해 메모리 오류가 발생할 수 있습니다. 이를 방지하려면 최신 버전으로 서버를 업데이트해야 합니다.
🇺🇸 원문 (English)
Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server
This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
📍 영향받는 시스템
Apache HTTP Server 2.4.0 - 2.4.67
⚔️ 공격 벡터
공격자가 제어하는 OCSP 서버를 통해 아웃바운드 요청을 유도하여 버퍼 오버리드 발생
🛡️ 대응 방법
Apache HTTP Server를 2.4.68 이상 버전으로 업그레이드
🔧 검증 코드
출력된 버전이 2.4.67 이하인 경우 취약한 것으로 판단하며, 2.4.68 이상이면 안전한 버전입니다.
httpd -v 2>/dev/null | grep -E 'version' || apachectl -v 2>/dev/null | grep -E 'version'