🇰🇷 한글 설명
Apache HTTP Server의 mod_proxy_ftp 모듈에서 백엔드 FTP 서버를 조종한 공격자가 무한 루프를 유발할 수 있는 취약점이 존재합니다. 이로 인해 서버가 응답하지 않거나 리소스가 고갈될 수 있으며, 버전 2.4.68로 업그레이드하여 해결해야 합니다.
💡 쉬운 설명
웹 서버가 외부 FTP 서버와 통신할 때, 공격자가 의도적으로 응답을 지연시켜 서버가 멈추게 만드는 문제입니다. 이를 방지하려면 Apache HTTP Server를 최신 버전으로 업데이트해야 합니다.
🇺🇸 원문 (English)
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in the mod_proxy_ftp module in Apache HTTP Server with an attacker controlled backend FTP server.
This issue affects undefined: from 2.4.0 through 2.4.67.
Users are recommended to upgrade to version 2.4.68, which fixes the issue.
📍 영향받는 시스템
Apache HTTP Server 2.4.0 through 2.4.67
⚔️ 공격 벡터
공격자가 제어하는 백엔드 FTP 서버를 통해 mod_proxy_ftp 모듈을 악용하여 무한 루프 발생
🛡️ 대응 방법
Apache HTTP Server를 버전 2.4.68 이상으로 업그레이드
🔧 검증 코드
출력된 버전 번호가 2.4.67 이하이면 취약하며, 2.4.68 이상이면 안전합니다.
httpd -v 2>/dev/null | grep -E 'version' || apachectl -v 2>/dev/null | grep -E 'version'