🇰🇷 한글 설명
RT(Request Tracker)는 오픈소스 엔터프라이즈 이슈 및 티켓 추적 시스템입니다. 버전 5.0.0 이상 5.0.10 미만 및 6.0.0 이상 6.0.3 미만에서 업로드된 콘텐츠를 첨부파일이 아닌 인라인으로 제공하여 크로스사이트 스크립팅(XSS) 취약점이 존재합니다. 이 취약점은 5.0.10 및 6.0.3 버전에서 수정되었습니다.
💡 쉬운 설명
인증된 사용자가 파일을 업로드할 때 그 안에 악성 스크립트를 넣을 수 있습니다. 이 파일을 나중에 다른 사용자가 열거나 다운로드하면 해당 사용자의 브라우저에서 스크립트가 실행됩니다.
🇺🇸 원문 (English)
RT is an open source, enterprise-grade issue and ticket tracking system. Versions 5.0.0 and 6.0.0 and above, prior to both 5.0.10 and 6.0.3 contain a Cross-Site Scripting (XSS) vulnerability where uploaded content is served inline rather than as an attachment. An authenticated user who can upload content can include JavaScript in the upload that will execute in the browser session of any RT user who later views or downloads it. This issue has been fixed in versions 5.0.10 and 6.0.3.
📍 영향받는 시스템
Best Practical Request Tracker(RT) 5.0.0~5.0.9 및 6.0.0~6.0.2
⚔️ 공격 벡터
인증된 사용자가 JavaScript가 포함된 파일을 업로드하고, 다른 RT 사용자가 이를 조회하거나 다운로드할 때 해당 사용자의 세션에서 스크립트가 실행됨
🛡️ 대응 방법
RT를 5.0.10 또는 6.0.3 이상으로 업그레이드
🔧 검증 코드
출력된 버전이 5.0.10 미만(5.0.x) 또는 6.0.3 미만(6.0.x)이면 취약하며, 그 이상이면 패치가 적용된 것입니다.
rt --version 2>/dev/null || grep -i '^version' /opt/rt*/lib/RT.pm 2>/dev/null