🇰🇷 한글 설명
PraisonAI 4.5.139~4.6.31 버전에서 tool_override.py의 보안 제한 부재로 인해 인증 없이 원격 코드 실행이 가능합니다. 공격자가 POST /v1/recipes/run을 통해 악의적인 tools.py를 삽입하면 서버에서 임의 코드가 실행됩니다.
💡 쉬운 설명
PraisonAI 서버의 레시피 실행 기능에 보안 결함이 있어 누구나 인터넷을 통해 악의적인 코드를 실행시킬 수 있습니다. 공격자의 코드가 서버에서 직접 실행되므로 매우 위험합니다.
🇺🇸 원문 (English)
PraisonAI is a multi-agent teams system. From version 4.5.139 to before version 4.6.32, CVE-2026-40287's fix gated tools.py auto-import behind PRAISONAI_ALLOW_LOCAL_TOOLS=true in two files (tool_resolver.py, api/call.py). A third import sink in praisonai/templates/tool_override.py was missed and remains unguarded. It is reached by the recipe runner on every recipe execution and is remotely triggerable through POST /v1/recipes/run with a recipe value pointing at any local absolute path or any GitHub repo (because SecurityConfig.allow_any_github defaults to True). The attacker drops a tools.py next to TEMPLATE.yaml; the server exec_module()s it. No auth required by default, no environment opt-in required. This issue has been patched in version 4.6.32.
📍 영향받는 시스템
PraisonAI 4.5.139 이상 4.6.32 미만
⚔️ 공격 벡터
인증 없이 POST /v1/recipes/run 엔드포인트에 악의적인 recipe 경로를 전송하여 원격 코드 실행
🛡️ 대응 방법
PraisonAI를 4.6.32 이상으로 즉시 업데이트
🔧 검증 코드
Version 항목이 4.6.32 이상이면 안전, 4.6.31 이하면 취약함
pip show praisonai 2>/dev/null | grep -i version