🔍 CVE-2026-44574

8.1
CVSS Score
HIGH
2026-05-13
2026-10-26 17:10
✅ 완료

🇰🇷 한글 설명

Next.js는 풀스택 웹 애플리케이션을 구축하기 위한 React 프레임워크입니다. 15.4.0 이상 15.5.16 미만 및 16.2.5 미만 버전에서, 미들웨어로 동적 라우트를 보호하는 애플리케이션이 권한 우회(Authorization Bypass)에 취약할 수 있습니다. 특수하게 조작된 쿼리 파라미터로 페이지가 인식하는 동적 라우트 값을 변경할 수 있으며, 이 경우 보이는 경로는 그대로 유지되어 예상된 미들웨어 검사를 거치지 않고 보호된 콘텐츠가 렌더링될 수 있습니다. 15.5.16 및 16.2.5에서 수정되었습니다.

💡 쉬운 설명

웹사이트의 접근 제한 검사(미들웨어)를 우회하여 로그인이나 권한이 필요한 페이지를 볼 수 있는 취약점입니다. 주소창의 겉모습은 그대로인데 내부적으로 다른 값이 처리되어 검사를 빠져나갑니다.

🇺🇸 원문 (English)

Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.

📍 영향받는 시스템

Next.js 15.4.0 이상 15.5.16 미만, 16.2.5 미만 버전을 사용하며 미들웨어로 동적 라우트를 보호하는 웹 애플리케이션

⚔️ 공격 벡터

조작된 쿼리 파라미터를 포함한 요청을 보내 동적 라우트 값을 변경하여 미들웨어 검사를 우회하고 보호된 페이지에 접근

🛡️ 대응 방법

Next.js를 15.5.16 또는 16.2.5 이상으로 업그레이드(npm install next@latest 또는 해당 버전 지정)

🔧 검증 코드

출력된 next 버전이 15.5.16 또는 16.2.5 미만이면 취약하며, 해당 버전 이상이면 패치가 적용된 것입니다.

Shell / Script
npm ls next 2>/dev/null | grep -E 'next@'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

💻 영향받는 소프트웨어

Next.js