🇰🇷 한글 설명
Next.js 자체 호스팅 애플리케이션의 내장 Node.js 서버가 WebSocket 업그레이드 요청을 통한 SSRF 취약점에 노출되어 있습니다. 공격자는 이를 악용하여 서버가 임의의 내부 또는 외부 대상으로 요청을 프록시하도록 강제할 수 있으며, 이는 내부 서비스나 클라우드 메타데이터 엔드포인트 노출로 이어질 수 있습니다. Vercel 호스팅 배포는 영향받지 않습니다.
💡 쉬운 설명
Next.js 웹 서버의 WebSocket 연결 기능을 악용해 공격자가 원하는 서버로 연결을 강제로 보낼 수 있습니다. 이를 통해 공격자는 내부 시스템이나 민감한 정보에 접근할 수 있습니다.
🇺🇸 원문 (English)
Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.
📍 영향받는 시스템
Next.js 13.4.13~15.5.15, 16.0~16.2.4 버전의 자체 호스팅 Node.js 서버
⚔️ 공격 벡터
조작된 WebSocket 업그레이드 요청을 통해 서버가 임의의 내부/외부 대상으로 프록시 요청을 전송하도록 유도
🛡️ 대응 방법
Next.js를 15.5.16 이상 또는 16.2.5 이상으로 즉시 업그레이드