🇰🇷 한글 설명
Portainer Community Edition의 특정 버전에서 Docker 플러그인 관리 엔드포인트가 적절한 핸들러 없이 노출되는 취약점이 발견되었습니다. 이로 인해 권한이 낮은 표준 사용자가 Docker 데몬에 직접 접근하여 플러그인 설치 및 활성화와 같은 특권 작업을 수행할 수 있습니다. 해당 취약점은 2.33.8, 2.39.2, 2.41.0 버전에서 수정되었습니다.
💡 쉬운 설명
일반 사용자 권한을 가진 사람이 관리자만 할 수 있는 중요한 설정을 마음대로 바꿀 수 있는 보안 구멍이 발견되었습니다. 공격자가 이를 이용해 허가되지 않은 프로그램을 설치하여 시스템을 장악할 위험이 있습니다.
🇺🇸 원문 (English)
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, The Docker plugin management endpoints (/plugins/*) were not registered with a handler, so standard users with endpoint access could call privileged plugin operations — including installing and enabling plugins — directly against the underlying Docker daemon. The vulnerability is exposed when a non-admin Portainer user (Standard User role, or any role granted endpoint-level access) has been given access to a Docker endpoint via Portainer RBAC. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
📍 영향받는 시스템
Portainer Community Edition 2.33.0 ~ 2.33.7, 2.39.0 ~ 2.39.1, 2.41.0 미만 버전
⚔️ 공격 벡터
RBAC를 통해 Docker 엔드포인트 접근 권한을 가진 표준 사용자가 `/plugins/*` 경로로 특권 명령을 직접 호출
🛡️ 대응 방법
Portainer를 최신 패치 버전(2.33.8, 2.39.2 또는 2.41.0 이상)으로 즉시 업데이트
🔧 검증 코드
명령어 결과에 취약한 버전 번호가 출력되면 해당 시스템은 보안 업데이트가 필요한 상태입니다.
curl -s http://localhost:9000/api/system/version | grep -E '"version":"(2\.33\.[0-7]|2\.39\.[0-1]|2\.41\.0)"'
🇰🇷 KISA(한국인터넷진흥원) 보안 권고
이 CVE에 대한 한국 공식 권고 (1건)
Portainer 제품 보안 업데이트 권고
P4
📅 2026-05-29 · sec_notice
Portainer 제품에서 권한 부여 누락(Missing Authorization) 취약점이 발견되었습니다. 해당 취약점에 노출된 사용자는 공격에 악용될 수 있으므로 최신 보안 버전으로 즉시 업데이트해야 합니다.