🔍 CVE-2026-44849

8.8
CVSS Score
HIGH
2026-05-28
2026-07-21 10:10
✅ 완료

🇰🇷 한글 설명

Portainer Community Edition에서 Docker Swarm 서비스 API를 사용할 때 관리자가 설정한 보안 제한 사항이 제대로 적용되지 않는 취약점입니다. 이로 인해 비관리자 사용자가 권한 상승이나 호스트 시스템 접근을 시도할 수 있는 보안 설정 우회 문제가 발생할 수 있습니다.

💡 쉬운 설명

관리자가 컨테이너의 위험한 기능을 막아두었음에도 불구하고, 특정 방식(Docker Swarm)으로 실행하면 이 제한이 무시되는 문제입니다. 공격자가 이를 이용해 원래는 허용되지 않는 높은 권한을 얻을 수 있습니다.

🇺🇸 원문 (English)

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.

📍 영향받는 시스템

Portainer Community Edition 2.33.0 ~ 2.33.7, 2.39.0 ~ 2.39.1, 2.41.0 미만 버전

⚔️ 공격 벡터

Docker Swarm 서비스 API를 통해 보안 제한이 적용되지 않는 경로로 컨테이너를 생성 및 실행

🛡️ 대응 방법

Portainer를 최신 패치 버전(2.33.8, 2.39.2, 2.41.0 이상)으로 업데이트

🔧 검증 코드

명령어 결과에 취약한 버전 번호가 출력되면 해당 시스템은 보안 업데이트가 필요한 상태입니다.

Shell / Script
curl -s http://localhost:9000/api/system/version | grep -E '"version":"(2\.33\.[0-7]|2\.39\.[0-1]|2\.41\.0)"'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Docker
🇰🇷 KISA(한국인터넷진흥원) 보안 권고 이 CVE에 대한 한국 공식 권고 (1건)
Portainer 제품 보안 업데이트 권고 P4
📅 2026-05-29 · sec_notice
Portainer 제품에서 권한 부여 누락(Missing Authorization) 취약점이 발견되었습니다. 해당 취약점에 노출된 사용자는 공격에 악용될 수 있으므로 최신 보안 버전으로 즉시 업데이트해야 합니다.
KISA 원문 →