🔍 CVE-2026-45048

8.5
CVSS Score
HIGH
2026-09-15
2026-09-23 18:19
✅ 완료

🇰🇷 한글 설명

Open Access Management(OpenAM) 16.1.1 미만 버전에서 세션 관리 엔드포인트의 SessionRequestHandler가 소유권 및 권한 확인을 강제하지 않는 취약점이 발견되었습니다. 공격자가 타겟 사용자의 식별자를 알 경우, 해당 사용자의 활성 세션 자격 증명을 탈취하여 권한이 높은 계정으로 세션을 하이재킹할 수 있습니다.

💡 쉬운 설명

로그인한 일반 사용자가 다른 사람의 세션 정보를 몰래 훔쳐볼 수 있는 보안 결함입니다. 이를 통해 관리자 같은 높은 권한을 가진 사용자의 계정을 가로챌 위험이 있습니다.

🇺🇸 원문 (English)

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, SessionRequestHandler in the session management endpoint does not enforce ownership or privilege checks when a low-privileged authenticated user queries session information in deployments using stateful session storage. A requester who knows a target identity identifier can retrieve another user's active session credentials, including credentials for a more privileged account, and use them to hijack that session. This issue is fixed in version 16.1.1.

📍 영향받는 시스템

Open Access Management (OpenAM) 16.1.1 미만 버전

⚔️ 공격 벡터

낮은 권한을 가진 인증된 사용자가 타겟의 식별자를 이용해 세션 정보 엔드포인트에 쿼리 전송

🛡️ 대응 방법

OpenAM을 최신 보안 패치가 적용된 버전인 16.1.1 이상으로 업데이트

🔧 검증 코드

출력된 버전 정보가 16.1.1 미만인지 확인하여 취약 여부를 판단합니다.

Shell / Script
curl -s http://<target-host>/openam/server-info | grep 'version' || echo 'Version check failed'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

💻 영향받는 소프트웨어

IBM Verify Identity Access