🔍 CVE-2026-45376

5.5
CVSS Score
MEDIUM
2026-07-31
2026-09-08 20:51
✅ 완료

🇰🇷 한글 설명

Decidim 참여 민주주의 프레임워크의 특정 버전에서 관리자 페이지의 사용자 검색 기능에 SQL 인젝션 취약점이 발견되었습니다. 인증된 조직 관리자가 특수하게 조작된 파라미터를 통해 PostgreSQL 명령어를 실행하고, 응답 시간 차이를 이용하여 데이터를 유추할 수 있습니다.

💡 쉬운 설명

관리자 권한을 가진 사용자가 검색창에 특수한 명령어를 입력하여 데이터베이스의 정보를 몰래 빼낼 수 있는 보안 약점입니다. 데이터베이스가 명령을 처리하는 속도 차이를 이용해 정보를 알아내는 방식입니다.

🇺🇸 원문 (English)

Decidim is a participatory democracy framework. Prior to 0.30.9, from 0.31.0 before 0.31.5, and in 0.32.0.rc1 before 0.32.0.rc2, the GET /admin/organization/users search interpolates params[:term] into raw Arel.sql ORDER BY similarity expressions before sanitization, allowing an authenticated organization administrator to execute blind PostgreSQL expressions and infer data through timing differences. This issue is fixed in versions 0.30.9, 0.31.5, and 0.32.0.rc2.

📍 영향받는 시스템

Decidim 0.30.9 미만, 0.31.0 이상 0.31.5 미만, 0.32.0.rc1 버전

⚔️ 공격 벡터

인증된 조직 관리자가 GET /admin/organization/users 요청의 params[:term] 파라미터에 조작된 SQL 구문을 삽입하여 공격

🛡️ 대응 방법

Decidim을 0.30.9, 0.31.5 또는 0.32.0.rc2 이상의 최신 버전으로 업데이트하십시오.

🔧 검증 코드

출력된 decidim의 버전이 취약한 버전 범위(0.30.9 미만, 0.31.0~0.31.4, 0.32.0.rc1)에 해당하는지 확인하십시오.

Shell / Script
gem list decidim

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:L

💻 영향받는 소프트웨어

PostgreSQL