🇰🇷 한글 설명
Apache Kvrocks의 cjson 라이브러리 내 Redis Lua HEAP 오버플로우 취약점입니다. 이 문제는 2.0.4 버전부터 2.15.0 버전까지의 Apache Kvrocks에 영향을 미칩니다.
💡 쉬운 설명
프로그램의 메모리 관리 오류로 인해 데이터가 넘쳐흐르는 문제가 발생할 수 있습니다. 이를 통해 공격자가 시스템을 조작하거나 오류를 일으킬 위험이 있습니다.
🇺🇸 원문 (English)
Redis Lua HEAP overflow in cjson library vulnerability in Apache Kvrocks.
This issue affects Apache Kvrocks: from 2.0.4 through 2.15.0.
Users are recommended to upgrade to version 2.16.0, which fixes the issue.
📍 영향받는 시스템
Apache Kvrocks 2.0.4 ~ 2.15.0
⚔️ 공격 벡터
cjson 라이브러리를 사용하는 Lua 스크립트 실행을 통한 메모리 오버플로우 유도
🛡️ 대응 방법
Apache Kvrocks를 취약점이 해결된 2.16.0 버전 이상으로 업그레이드하십시오.
🔧 검증 코드
출력된 버전이 2.16.0 미만(2.0.4~2.15.0 사이)인지 확인하십시오.
kvrocks --version 2>/dev/null || echo 'Version not found'