🇰🇷 한글 설명
오픈 소스 리치 텍스트 에디터인 TinyMCE에서 발생하는 저장형 XSS 취약점입니다. 검증되지 않은 data-mce-* 속성을 통해 공격자가 악성 값을 주입하여 직렬화 과정 중 보안 검증을 우회할 수 있습니다.
💡 쉬운 설명
웹사이트 글쓰기 도구에 악성 코드를 숨겨서 저장할 수 있는 보안 약점입니다. 이 코드가 실행되면 사용자의 정보를 훔치거나 웹사이트를 마음대로 조작할 수 있습니다.
🇺🇸 원문 (English)
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
📍 영향받는 시스템
TinyMCE 버전 5.11.1 미만, 7.9.3 미만, 8.5.1 미만
⚔️ 공격 벡터
검증되지 않은 data-mce-href, data-mce-src, data-mce-style 속성에 악성 스크립트를 주입하여 공격
🛡️ 대응 방법
TinyMCE를 최신 패치 버전(5.11.1, 7.9.3, 8.5.1 이상)으로 업데이트
🔧 검증 코드
출력된 TinyMCE의 버전을 확인하여 취약한 버전 범위에 해당하는지 체크