🔍 CVE-2026-48778

7.8
CVSS Score
HIGH
2026-06-26
2026-06-29 21:22
✅ 완료

🇰🇷 한글 설명

Notepad++ 8.9.6.1 미만 버전에서 config.xml 파일의 <GUIConfig name="commandLineInterpreter"> 태그 값이 검증 없이 처리되는 취약점이 발견되었습니다. 공격자가 이 값을 조작하면 사용자가 특정 메뉴를 실행할 때 임의의 명령어가 실행될 수 있습니다.

💡 쉬운 설명

메모장 프로그램의 설정 파일이 조작되면, 사용자가 폴더 열기 같은 일반적인 기능을 사용할 때 해커가 심어둔 악성 프로그램이 몰래 실행될 수 있는 문제입니다.

🇺🇸 원문 (English)

Notepad++ is a free and open-source source code editor. Prior to 8.9.6.1, the <GUIConfig name="commandLineInterpreter"> tag in config.xml is read by NppXml::value() (Parameters.cpp:6430) and stored in _nppGUI._commandLineInterpreter without any validation, whitelist, or digital signature check. When the user triggers IDM_FILE_OPEN_CMD (File → Open Containing Folder → cmd), NppCommands.cpp:228 creates a Command object with this value and calls run(), which invokes ShellExecute (RunDlg.cpp:221) with the attacker-controlled string as the executable path. This vulnerability is fixed in 8.9.6.1.

📍 영향받는 시스템

Notepad++ 8.9.6.1 미만 모든 버전

⚔️ 공격 벡터

조작된 config.xml 파일을 통한 설정값 변조 후 특정 GUI 명령 실행

🛡️ 대응 방법

Notepad++를 최신 버전인 8.9.6.1 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 번호가 8.9.6.1보다 낮은지 확인하십시오.

Shell / Script
notepadpp --version 2>/dev/null || powershell "(Get-Item 'C:\Program Files\Notepad++\notepad++.exe').VersionInfo.FileVersion"

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Notepad++
🇰🇷 KISA(한국인터넷진흥원) 보안 권고 이 CVE에 대한 한국 공식 권고 (1건)
Notepad++ 제품 보안 업데이트 권고 P4
📅 2026-06-01 · sec_notice
Notepad++ 제품에서 Out-of-bounds Read 및 OS Command Injection 취약점이 발견되었습니다. 영향을 받는 버전의 사용자는 원격 코드 실행 등의 위험을 방지하기 위해 최신 보안 버전으로 즉시 업데이트해야 합니다.
KISA 원문 →