🔍 CVE-2026-50191

8.8
CVSS Score
HIGH
2026-08-18
2026-10-22 17:09
✅ 완료

🇰🇷 한글 설명

4gaBoards 3.3.8 미만 버전에서 발생하는 계정 탈취 취약점입니다. 공격자가 피해자의 이메일로 미인증 로컬 계정을 생성한 뒤, 피해자가 SSO(Google, GitHub 등)로 로그인할 때 해당 계정이 자동으로 연결되어 공격자가 피해자의 데이터와 권한에 접근할 수 있습니다.

💡 쉬운 설명

공격자가 당신의 이메일 주소로 가짜 계정을 미리 만들어 놓은 뒤, 당신이 구글이나 깃허브로 로그인하는 순간 두 계정을 하나로 합쳐버리는 공격입니다. 이를 통해 공격자는 당신의 프로젝트와 개인 정보에 마음대로 접근할 수 있게 됩니다.

🇺🇸 원문 (English)

4gaBoards is a boards system for realtime project management. Prior to 3.3.8, 4gaBoards is vulnerable to pre-account takeover when registrationEnabled, localRegistrationEnabled, and ssoRegistrationEnabled are enabled and Google, GitHub, Microsoft, or OIDC SSO is configured. The POST /api/register endpoint permits creation of an unverified local account with a victim's email address, and POST /api/access-tokens permits that account to authenticate while isVerified is false. During the victim's first SSO login, server/api/helpers/users/get-create-one-for-github-sso.js, server/api/helpers/users/get-create-one-for-google-sso.js, server/api/helpers/users/get-create-one-for-microsoft-sso.js, and server/api/helpers/users/get-create-one-for-oidc-sso.js find the attacker-controlled account by email and link the verified SSO identity without confirming ownership of the local account. The attacker can retain local-password access to the linked account and obtain the victim's projects, data, and permissions. This issue is fixed in version 3.3.8.

📍 영향받는 시스템

4gaBoards version < 3.3.8 (registrationEnabled, localRegistrationEnabled, ssoRegistrationEnabled가 활성화된 경우)

⚔️ 공격 벡터

POST /api/register를 통한 미인증 계정 생성 후 SSO 로그인 시 계정 연동 유도

🛡️ 대응 방법

4gaBoards를 최신 버전인 3.3.8 이상으로 업데이트하십시오.

🔧 검증 코드

명령어 결과에 3.3.8 미만의 버전 번호가 출력되면 해당 취약점에 노출된 상태입니다.

Shell / Script
curl -s http://<target-ip>/api/version | grep -E '3\.[0-3]\.[0-7]'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Git