🔍 CVE-2026-52769

8.3
CVSS Score
HIGH
2026-09-05
2026-09-08 21:05
✅ 완료

🇰🇷 한글 설명

YesWiki 4.6.2 버전부터 4.6.6 미만 버전에서 발생하는 취약점으로, 공개된 API 경로를 통해 서버가 임의의 URL로 HTTP 요청을 보내도록 유도할 수 있습니다. 공격자는 이를 통해 내부 네트워크 스캔, 클라우드 메타데이터 탈취, 인트라넷 서비스 접근 등의 SSRF 공격을 수행할 수 있습니다.

💡 쉬운 설명

해커가 웹사이트에 가짜 요청을 보내면, 웹사이트 서버가 해커가 원하는 곳(내부 서버나 관리자 페이지 등)에 대신 접속하게 만드는 보안 구멍입니다. 이를 통해 해커는 원래 접근할 수 없는 내부 정보나 클라우드 설정 정보를 훔쳐볼 수 있습니다.

🇺🇸 원문 (English)

YesWiki is a wiki system written in PHP. From version 4.6.2 to before version 4.6.6, the POST /api/forms/{formId}/actor/inbox route - exposed publicly with acl:"public" - accepts an HTTP Signature header whose keyId parameter is a URL. HttpSignatureService::verifySignature() parses the header and immediately makes a server-side HTTP GET to that URL, before any cryptographic verification or URL validation. An unauthenticated remote attacker can therefore make YesWiki issue arbitrary outbound HTTP requests to any host the server can reach - internal services, cloud-metadata endpoints (169.254.169.254), intranet-only admin panels, etc. - and read enough back via timing and error-message oracles to scan ports, enumerate services, and (on a real cloud instance) reach IAM metadata. The only deployment-side precondition is that ActivityPub be enabled on at least one Bazar form. This issue has been patched in version 4.6.6.

📍 영향받는 시스템

YesWiki 4.6.2 ~ 4.6.5 (4.6.6 미만 버전)

⚔️ 공격 벡터

인증되지 않은 공격자가 HTTP Signature 헤더의 keyId 파라미터에 악의적인 URL을 삽입하여 서버 측 SSRF 유도

🛡️ 대응 방법

YesWiki를 최신 보안 패치가 적용된 4.6.6 버전 이상으로 즉시 업데이트하십시오.

🔧 검증 코드

설치된 YesWiki의 버전을 확인하여 4.6.6 미만 버전인지 확인합니다.

Shell / Script
php -r 'echo "YesWiki Version Check";' | grep -i '4.6.'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

💻 영향받는 소프트웨어

Cloud Services