🔍 CVE-2026-52774

6.1
CVSS Score
MEDIUM
2026-09-05
2026-09-08 21:05
✅ 완료

🇰🇷 한글 설명

PHP 기반 위키 시스템인 YesWiki 4.6.6 미만 버전에서 Bazar 위젯 핸들러의 id GET 파라미터에 대한 취약점이 발견되었습니다. strip_tags() 함수가 큰따옴표를 제대로 이스케이프하지 못해 공격자가 HTML 속성을 탈출하고 자바스크립트를 주입할 수 있는 XSS 취약점이 존재합니다. 이 문제는 인증 없이도 실행 가능하며 Bazar 확장이 활성화된 상태에서 발생합니다.

💡 쉬운 설명

웹사이트의 특정 기능에 특수 문자를 입력하여 공격자가 만든 악성 코드를 실행시키는 보안 약점입니다. 로그인을 하지 않은 일반 방문자라도 이 코드를 통해 사용자의 브라우저에서 원치 않는 동작을 수행하게 만들 수 있습니다.

🇺🇸 원문 (English)

YesWiki is a wiki system written in PHP. Prior to version 4.6.6, YesWiki's Bazar widget handler reflects the id GET parameter into HTML attributes using strip_tags() only. Because strip_tags() does not escape double quotes, an attacker can break out of the attribute value, inject an event handler such as onmouseover, and execute arbitrary JavaScript in the victim's browser. This issue is reachable without authentication. During validation, the vulnerable widget route returned the injected HTML for both /HomePage/widget?id=... and /NoSuchPage/widget?id=..., which shows that no login, no page ownership, no edit rights, and not even a valid page tag were required. The only routing prerequisite observed was that the Bazar extension is enabled and the request includes an id parameter. This issue has been patched in version 4.6.6.

📍 영향받는 시스템

YesWiki 4.6.6 미만 버전 (Bazar 확장 기능 활성화 시)

⚔️ 공격 벡터

인증되지 않은 공격자가 Bazar 위젯의 id 파라미터에 악성 HTML 속성 및 자바스크립트 이벤트 핸들러를 주입하여 공격

🛡️ 대응 방법

YesWiki를 최신 보안 패치가 적용된 버전인 4.6.6 이상으로 업데이트하십시오.

🔧 검증 코드

설치된 YesWiki의 버전을 확인하여 4.6.6 미만인지 확인합니다.

Shell / Script
php -r "echo 'YesWiki version check logic here';" | grep -E '4.6.6'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

💻 영향받는 소프트웨어

PHP