🇰🇷 한글 설명
Apache Hive 4.0.0부터 4.2.0 버전까지의 HiveServer2에서 SAML 인증 검증 과정에 부적절한 인증 취약점이 발견되었습니다. HTTP 전송 모드에서 SAML 인증을 사용하는 경우, 공격자가 위조된 Bearer 토큰을 사용하여 인증 없이 임의의 사용자로 로그인할 수 있습니다.
💡 쉬운 설명
해커가 가짜 신분증(토큰)을 만들어 서버에 보내면, 서버가 이를 진짜로 착각하고 문을 열어주는 보안 결함입니다. 이를 통해 공격자는 아무런 권한 없이도 데이터베이스에 접속하여 정보를 훔칠 수 있습니다.
🇺🇸 원문 (English)
An improper authentication vulnerability in HiveServer2 SAML bearer-token validation in Apache Hive 4.0.0 through 4.2.0 (and later unreleased branches) on deployments using HTTP transport with hive.server2.authentication=SAML allows an unauthenticated network attacker to authenticate as an arbitrary Hive user and obtain an authenticated HiveServer2 session via a forged Authorization: Bearer token sent to the /cliservice HTTP endpoint. Users are recommended to upgrade to 4.2.1 version that includes the fix for this issue.
Access / authorization required: No Hive credentials, SAML IdP login, or knowledge of the server signing secret is required. The attacker only needs network reachability to the HiveServer2 HTTP port (typically /cliservice), directly or through a reverse proxy such as Apache Knox that forwards unauthenticated requests to HS2. The instance must have SAML authentication enabled in HTTP mode. Deployments where Knox handles SSO and HiveServer2 uses LDAP/Kerberos (not native SAML mode) are not affected by this specific issue.
📍 영향받는 시스템
Apache Hive 4.0.0 ~ 4.2.0 (SAML 인증 및 HTTP 모드 사용 시)
⚔️ 공격 벡터
HTTP 전송 모드에서 /cliservice 엔드포인트로 위조된 Authorization: Bearer 토큰을 전송하여 인증 우회
🛡️ 대응 방법
취약점이 해결된 Apache Hive 4.2.1 버전 이상으로 업그레이드
🔧 검증 코드
명령어 결과에 4.0.x, 4.1.x, 4.2.0 버전이 나타나면 취약한 버전이 설치된 상태입니다.
hive --version 2>/dev/null | grep -E '4\[0-2]\.'