🔍 CVE-2026-53572

5.9
CVSS Score
MEDIUM
2026-08-21
2026-10-12 16:10
✅ 완료

🇰🇷 한글 설명

KEDA 2.20.0 미만 버전에서 PostgreSQL 스케일러가 연결 문자열을 생성할 때 특수 문자를 적절히 처리하지 못하는 취약점이 발견되었습니다. 공격자가 제어 가능한 입력값에 탭이나 줄바꿈 등의 문자를 삽입하여 연결 파라미터를 조작할 수 있습니다. 이를 통해 데이터베이스 연결을 공격자 서버로 리다이렉트하거나 자격 증명을 탈취하고 TLS 보호를 무력화할 수 있습니다.

💡 쉬운 설명

KEDA라는 프로그램이 데이터베이스에 연결할 때 사용하는 주소 설정 방식에 허점이 있습니다. 나쁜 사용자가 특수 문자를 섞어 넣으면 데이터베이스 연결 정보를 가로채거나 보안 설정을 끌 수 있습니다.

🇺🇸 원문 (English)

KEDA is a Kubernetes-based Event Driven Autoscaling component. Prior to 2.20.0, pkg/scalers/postgresql_scaler.go constructs libpq-style connection strings from tenant-controlled host, port, userName, dbName, sslmode, and password values, while escapePostgreConnectionParameter() only quotes values containing a literal space. Tabs, newlines, carriage returns, form feeds, vertical tabs, quotes, and backslashes can therefore create additional key-value tokens when pgx parses the string. An attacker able to create or modify a TriggerAuthentication or ScaledObject can inject host or sslmode parameters, redirect the database connection to an attacker-controlled server, expose credentials, or disable intended TLS protection. This issue is fixed in version 2.20.0.

📍 영향받는 시스템

KEDA versions prior to 2.20.0

⚔️ 공격 벡터

TriggerAuthentication 또는 ScaledObject를 생성하거나 수정할 수 있는 권한을 이용한 파라미터 주입

🛡️ 대응 방법

KEDA를 2.20.0 버전 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 KEDA의 버전이 2.20.0 미만인지 확인하십시오.

Shell / Script
helm list -A | grep keda | awk '{print $2}' | xargs helm get values keda -n <namespace> | grep version || echo 'Check KEDA version manually'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N

💻 영향받는 소프트웨어

Kubernetes