🔍 CVE-2026-53932

8.0
CVSS Score
HIGH
2026-09-04
2026-09-10 20:41
✅ 완료

🇰🇷 한글 설명

laravel-backup-restore 패키지 1.9.4 미만 버전에서 데이터베이스 복구 시 OS 명령 주입(Command Injection) 취약점이 존재합니다. 공격자가 조작된 백업 아카이브를 사용하여 시스템 명령을 실행할 수 있습니다.

💡 쉬운 설명

백업 파일을 복구하는 과정에서 해커가 심어놓은 악성 명령어가 컴퓨터에서 실행될 수 있는 문제입니다. 이로 인해 해커가 서버의 제어권을 완전히 가져갈 위험이 있습니다.

🇺🇸 원문 (English)

laravel-backup-restore restores database backups made with spatie/laravel-backup. Prior to version 1.9.4, a crafted backup archive can trigger OS command injection during database restore. This issue has been patched in version 1.9.4.

📍 영향받는 시스템

laravel-backup-restore version < 1.9.4

⚔️ 공격 벡터

조작된 데이터베이스 백업 아카이브 파일을 업로드하여 복구 프로세스를 실행함

🛡️ 대응 방법

laravel-backup-restore 패키지를 1.9.4 버전 이상으로 업데이트하십시오.

🔧 검증 코드

출력된 버전 정보가 1.9.4 미만인지 확인하십시오.

Shell / Script
composer show spatie/laravel-backup | grep 'versions'

📊 CVSS Vector String

CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

💻 영향받는 소프트웨어

Spring Data REST